SimpleLPR3 Namespace

SimpleLPR3 ANPR engine classes.
Classes
 | Class | Description
Public class | SimpleLPR | SimpleLPR factory class.
Structures
 | Structure | Description
Public structure | Candidate | Encapsulates a license plate candidate.
Public structure | CountryMatch | Encapsulates possible country match for a license plate candidate.
Public structure | Element | Encapsulates a candidate character in a license plate.
Public structure | EngineSetupParms | SimpleLPR engine initialization parameters. In case of a CUDA compatible GPU is available in the system it can be selected to off-load some computation intensive tasks from the CPU. When the GPU mode is selected, the user can independently enable the GPU for image processing tasks and/or text candidate classification. Moreover, since some of the image processing algorithms used in SimpleLPR are memory consuming an additional parameter is provided that allows the user to specify the maximum number of concurrent image processing operations.
Public structure | VersionNumber | Encapsulates the application version number.
Interfaces
 | Interface | Description
Public interface | IProcessor | Provides access to the license plate recognition functionality of SimpleLPR.
Public interface | ISimpleLPR | Encapsulates the SimpleLPR engine.


Candidate Structure

Encapsulates a license plate candidate.
Inheritance Hierarchy
SystemObject
SystemValueType
SimpleLPR3Candidate

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public struct Candidate

The Candidate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | bbox | Bounding box of the text in the license plate candidate, in pixel coordinates.
Public field | brightBackground | True if the license plate features dark text on a light background. False otherwise.
Public field | matches | List of possible country matches for the license plate candidate. The last entry in the list corresponds to the raw text before syntax validation.
Public field | plateDetectionConfidence | Estimated probability that the candidate corresponds to a license plate rather than incidental scene text, or -1 in case that the plate region detection and extraction feature has not been previously enabled in IProcessor
Public field | plateRegionVertices | Contains the four vertices of the detected license plate region in case that plateRegionDetectionConfidence > 0, otherwise all point coordinates are set to -1
Top
See Also

Reference

SimpleLPR3 Namespace


Candidate Methods

The Candidate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
See Also

Reference

Candidate Structure


Candidate Fields

The Candidate type exposes the following members.

Fields
 | Name | Description
Public field | bbox | Bounding box of the text in the license plate candidate, in pixel coordinates.
Public field | brightBackground | True if the license plate features dark text on a light background. False otherwise.
Public field | matches | List of possible country matches for the license plate candidate. The last entry in the list corresponds to the raw text before syntax validation.
Public field | plateDetectionConfidence | Estimated probability that the candidate corresponds to a license plate rather than incidental scene text, or -1 in case that the plate region detection and extraction feature has not been previously enabled in IProcessor
Public field | plateRegionVertices | Contains the four vertices of the detected license plate region in case that plateRegionDetectionConfidence > 0, otherwise all point coordinates are set to -1
Top
See Also

Reference

Candidate Structure


Candidate.bbox Field

SimpleLPR 3.5.1 reference for .NET

Candidatebbox Field

Bounding box of the text in the license plate candidate, in pixel coordinates.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public Rectangle bbox

Field Value

Rectangle
See Also

Reference

Candidate Structure


Candidate.brightBackground Field

CandidatebrightBackground Field

True if the license plate features dark text on a light background. False otherwise.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public bool brightBackground

Field Value

Boolean
See Also

Reference

Candidate Structure


Candidate.matches Field

Candidatematches Field

List of possible country matches for the license plate candidate. The last entry in the list corresponds to the raw text before syntax validation.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public List<CountryMatch> matches

Field Value

List CountryMatch
See Also

Reference

Candidate Structure


Candidate.plateDetectionConfidence Field

CandidateplateDetectionConfidence Field

Estimated probability that the candidate corresponds to a license plate rather than incidental scene text, or -1 in case that the plate region detection and extraction feature has not been previously enabled in IProcessor

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public float plateDetectionConfidence

Field Value

Single
See Also

Reference

Candidate Structure


Candidate.plateRegionVertices Field

CandidateplateRegionVertices Field

Contains the four vertices of the detected license plate region in case that plateRegionDetectionConfidence > 0, otherwise all point coordinates are set to -1

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public Point[] plateRegionVertices

Field Value

Point
See Also

Reference

Candidate Structure


CountryMatch Structure

Encapsulates possible country match for a license plate candidate.
Inheritance Hierarchy
SystemObject
SystemValueType
SimpleLPR3CountryMatch

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public struct CountryMatch

The CountryMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | bbox | Bounding box of the text in the country match, in pixel coordinates.
Public field | confidence | Overall 'goodness' of the recognition. Currently it is calculated as the product of the confidences of the elements in the country match. See Element.confidence.
Public field | country | Country code string.
Public field | countryISO | Country ISO Alpha-2 code.
Public field | elements | Information about the individual characters that make up the license plate. They are listed in the same order as they appear in the text string. To know the physical layout use the bbox field.
Public field | text | Unicode representation of the license plate string.
Top
See Also

Reference

SimpleLPR3 Namespace


CountryMatch Methods

The CountryMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
See Also

Reference

CountryMatch Structure


CountryMatch Fields

The CountryMatch type exposes the following members.

Fields
 | Name | Description
Public field | bbox | Bounding box of the text in the country match, in pixel coordinates.
Public field | confidence | Overall 'goodness' of the recognition. Currently it is calculated as the product of the confidences of the elements in the country match. See Element.confidence.
Public field | country | Country code string.
Public field | countryISO | Country ISO Alpha-2 code.
Public field | elements | Information about the individual characters that make up the license plate. They are listed in the same order as they appear in the text string. To know the physical layout use the bbox field.
Public field | text | Unicode representation of the license plate string.
Top
See Also

Reference

CountryMatch Structure


CountryMatch.bbox Field

CountryMatchbbox Field

Bounding box of the text in the country match, in pixel coordinates.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public Rectangle bbox

Field Value

Rectangle
See Also

Reference

CountryMatch Structure


CountryMatch.confidence Field

CountryMatchconfidence Field

Overall 'goodness' of the recognition. Currently it is calculated as the product of the confidences of the elements in the country match. See Element.confidence.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public float confidence

Field Value

Single
See Also

Reference

CountryMatch Structure


CountryMatch.country Field

CountryMatchcountry Field

Country code string.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public string country

Field Value

String
See Also

Reference

CountryMatch Structure


CountryMatch.countryISO Field

CountryMatchcountryISO Field

Country ISO Alpha-2 code.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public string countryISO

Field Value

String
See Also

Reference

CountryMatch Structure


CountryMatch.elements Field

CountryMatchelements Field

Information about the individual characters that make up the license plate. They are listed in the same order as they appear in the text string. To know the physical layout use the bbox field.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public List<Element> elements

Field Value

List Element
See Also

Reference

CountryMatch Structure


CountryMatch.text Field

CountryMatchtext Field

Unicode representation of the license plate string.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public string text

Field Value

String
See Also

Reference

CountryMatch Structure


Element Structure

Encapsulates a candidate character in a license plate.
Inheritance Hierarchy
SystemObject
SystemValueType
SimpleLPR3Element

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public struct Element

The Element type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | bbox | Bounding box of the character, in pixel coordinates.
Public field | confidence | 'Goodness' of the recognition. Its range is 0 to 1 and can be used to rank candidates although it should not be regarded as a probability. In general, a 2x goodness value is not twice as good as x.
Public field | glyph | Unicode representation of the character.
Top
See Also

Reference

SimpleLPR3 Namespace


Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
See Also

Reference

Element Structure


Element Fields

The Element type exposes the following members.

Fields
 | Name | Description
Public field | bbox | Bounding box of the character, in pixel coordinates.
Public field | confidence | 'Goodness' of the recognition. Its range is 0 to 1 and can be used to rank candidates although it should not be regarded as a probability. In general, a 2x goodness value is not twice as good as x.
Public field | glyph | Unicode representation of the character.
Top
See Also

Reference

Element Structure


Element.bbox Field

Elementbbox Field

Bounding box of the character, in pixel coordinates.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public Rectangle bbox

Field Value

Rectangle
See Also

Reference

Element Structure


Element.confidence Field

Elementconfidence Field

'Goodness' of the recognition. Its range is 0 to 1 and can be used to rank candidates although it should not be regarded as a probability. In general, a 2x goodness value is not twice as good as x.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public float confidence

Field Value

Single
See Also

Reference

Element Structure


Element.glyph Field

Elementglyph Field

Unicode representation of the character.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public char glyph

Field Value

Char
See Also

Reference

Element Structure


EngineSetupParms Structure

SimpleLPR engine initialization parameters. In case of a CUDA compatible GPU is available in the system it can be selected to off-load some computation intensive tasks from the CPU. When the GPU mode is selected, the user can independently enable the GPU for image processing tasks and/or text candidate classification. Moreover, since some of the image processing algorithms used in SimpleLPR are memory consuming an additional parameter is provided that allows the user to specify the maximum number of concurrent image processing operations.
Inheritance Hierarchy
SystemObject
SystemValueType
SimpleLPR3EngineSetupParms

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public struct EngineSetupParms

The EngineSetupParms type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | cudaDeviceId | -1 : Use CPU. Otherwise: CUDA device identifier, usually 0 corresponds to the default device.
Public field | enableClassificationWithGPU | If true, use the GPU for candidate classification in case a valid cuda device identifier is provided.
Public field | enableImageProcessingWithGPU | If true, use the GPU for image processing tasks in case a valid cuda device identifier is provided.
Public field | maxConcurrentImageProcessingOps | Maximum number of concurrent image processing operations. The recommended values are 1 or 2 when using the CPU for image processing tasks, and 4 or more when employing a GPU. Setting this parameter to 0 is equivalent to selecting the recommended values for each case.
Top
See Also

Reference

SimpleLPR3 Namespace


EngineSetupParms Methods

The EngineSetupParms type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
See Also

Reference

EngineSetupParms Structure


EngineSetupParms Fields

The EngineSetupParms type exposes the following members.

Fields
 | Name | Description
Public field | cudaDeviceId | -1 : Use CPU. Otherwise: CUDA device identifier, usually 0 corresponds to the default device.
Public field | enableClassificationWithGPU | If true, use the GPU for candidate classification in case a valid cuda device identifier is provided.
Public field | enableImageProcessingWithGPU | If true, use the GPU for image processing tasks in case a valid cuda device identifier is provided.
Public field | maxConcurrentImageProcessingOps | Maximum number of concurrent image processing operations. The recommended values are 1 or 2 when using the CPU for image processing tasks, and 4 or more when employing a GPU. Setting this parameter to 0 is equivalent to selecting the recommended values for each case.
Top
See Also

Reference

EngineSetupParms Structure


EngineSetupParms.cudaDeviceId Field

EngineSetupParmscudaDeviceId Field

-1 : Use CPU. Otherwise: CUDA device identifier, usually 0 corresponds to the default device.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int cudaDeviceId

Field Value

Int32
See Also

Reference

EngineSetupParms Structure


EngineSetupParms.enableClassificationWithGPU Field

EngineSetupParmsenableClassificationWithGPU Field

If true, use the GPU for candidate classification in case a valid cuda device identifier is provided.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public bool enableClassificationWithGPU

Field Value

Boolean
See Also

Reference

EngineSetupParms Structure


EngineSetupParms.enableImageProcessingWithGPU Field

EngineSetupParmsenableImageProcessingWithGPU Field

If true, use the GPU for image processing tasks in case a valid cuda device identifier is provided.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public bool enableImageProcessingWithGPU

Field Value

Boolean
See Also

Reference

EngineSetupParms Structure


EngineSetupParms.maxConcurrentImageProcessingOps Field

EngineSetupParmsmaxConcurrentImageProcessingOps Field

Maximum number of concurrent image processing operations. The recommended values are 1 or 2 when using the CPU for image processing tasks, and 4 or more when employing a GPU. Setting this parameter to 0 is equivalent to selecting the recommended values for each case.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int maxConcurrentImageProcessingOps

Field Value

Int32
See Also

Reference

EngineSetupParms Structure


IProcessor Interface

Provides access to the license plate recognition functionality of SimpleLPR.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public interface IProcessor : IDisposable

The IProcessor type exposes the following members.

Properties
 | Name | Description
Public property | contrastSensitivityFactor | Gets/sets the contrast sensitivity factor (CSF) parameter for the IProcessor.
Public property | cropToPlateRegionEnabled | Enables/disables the crop to plate region functionality. When set to true, results are cropped to the region of the detected plate
Public property | numSupportedCountries | Number of supported countries.
Public property | plateRegionDetectionEnabled | Enables/disables the plate region detection and extraction functionality.
Top
Methods
 | Name | Description
Public method | analyze(Byte) | Looks for license plate candidates in a .jpg, .png or .tif encoded image in a buffer in memory. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(Stream) | Looks for license plate candidates in a .jpg, .png or .tif encoded image loaded from a Stream. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(String) | Looks for license plate candidates in an image loaded from a .jpg, .png or .tif file. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(IntPtr, UInt32, UInt32, UInt32) | Looks for license plate candidates in a memory buffer containing a 8 bit gray scale image.
Public method | analyze_C3 | Looks for license plate candidates in a memory buffer containing a 3-channel 8 bit/channel color image stored in pixel order. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114
Public method | analyze_C4 | Looks for license plate candidates in a memory buffer containing a 4-channel 8 bit/channel color image stored in pixel order. The fourth byte in each pixel is not used. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114
Public method | Dispose | (Inherited from IDisposable)
Public method | get_countryCode | Given a country index it returns its string identifier.
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | realizeCountryWeights | Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
Remarks
This class is not multi-threaded and, therefore, each thread should use a different IProcessor instance.
See Also

Reference

SimpleLPR3 Namespace


IProcessor Properties

The IProcessor type exposes the following members.

Properties
 | Name | Description
Public property | contrastSensitivityFactor | Gets/sets the contrast sensitivity factor (CSF) parameter for the IProcessor.
Public property | cropToPlateRegionEnabled | Enables/disables the crop to plate region functionality. When set to true, results are cropped to the region of the detected plate
Public property | numSupportedCountries | Number of supported countries.
Public property | plateRegionDetectionEnabled | Enables/disables the plate region detection and extraction functionality.
Top
See Also

Reference

IProcessor Interface


IProcessor.contrastSensitivityFactor Property

IProcessorcontrastSensitivityFactor Property

Gets/sets the contrast sensitivity factor (CSF) parameter for the IProcessor.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
float contrastSensitivityFactor { get; set; }

Property Value

Single
Current contrast sensitivity factor (CSF) parameter for the IProcessor.
Remarks
The CSF parameter must lie in the interval [0..1]. Low CSF values can help in cases such as shadows in plates. Otherwise higher CSF values are recommended.
See Also

Reference

IProcessor Interface


IProcessor.cropToPlateRegionEnabled Property

IProcessorcropToPlateRegionEnabled Property

Enables/disables the crop to plate region functionality. When set to true, results are cropped to the region of the detected plate

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
bool cropToPlateRegionEnabled { get; set; }

Property Value

Boolean
true to enable the crop to plate region functionality and false to disable it.
See Also

Reference

IProcessor Interface


IProcessor.numSupportedCountries Property

IProcessornumSupportedCountries Property

Number of supported countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
uint numSupportedCountries { get; }

Property Value

UInt32
The number of supported countries.
See Also

Reference

IProcessor Interface


IProcessor.plateRegionDetectionEnabled Property

IProcessorplateRegionDetectionEnabled Property

Enables/disables the plate region detection and extraction functionality.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
bool plateRegionDetectionEnabled { get; set; }

Property Value

Boolean
true to enable the plate detection and extraction functionality and false to disable it.
See Also

Reference

IProcessor Interface


IProcessor Methods

The IProcessor type exposes the following members.

Methods
 | Name | Description
Public method | analyze(Byte) | Looks for license plate candidates in a .jpg, .png or .tif encoded image in a buffer in memory. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(Stream) | Looks for license plate candidates in a .jpg, .png or .tif encoded image loaded from a Stream. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(String) | Looks for license plate candidates in an image loaded from a .jpg, .png or .tif file. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(IntPtr, UInt32, UInt32, UInt32) | Looks for license plate candidates in a memory buffer containing a 8 bit gray scale image.
Public method | analyze_C3 | Looks for license plate candidates in a memory buffer containing a 3-channel 8 bit/channel color image stored in pixel order. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114
Public method | analyze_C4 | Looks for license plate candidates in a memory buffer containing a 4-channel 8 bit/channel color image stored in pixel order. The fourth byte in each pixel is not used. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114
Public method | Dispose | (Inherited from IDisposable)
Public method | get_countryCode | Given a country index it returns its string identifier.
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | realizeCountryWeights | Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
See Also

Reference

IProcessor Interface


IProcessor.analyze Method

IProcessoranalyze Method

Overload List
 | Name | Description
Public method | analyze(Byte) | Looks for license plate candidates in a .jpg, .png or .tif encoded image in a buffer in memory. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(Stream) | Looks for license plate candidates in a .jpg, .png or .tif encoded image loaded from a Stream. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(String) | Looks for license plate candidates in an image loaded from a .jpg, .png or .tif file. The images can be either 24 bit RGB or 8 bit gray scale.
Public method | analyze(IntPtr, UInt32, UInt32, UInt32) | Looks for license plate candidates in a memory buffer containing a 8 bit gray scale image.
Top
See Also

Reference

IProcessor Interface


IProcessor.analyze(Byte[]) Method

IProcessoranalyze(Byte) Method

Looks for license plate candidates in a .jpg, .png or .tif encoded image in a buffer in memory. The images can be either 24 bit RGB or 8 bit gray scale.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze(
    byte[] imgData
)

Parameters

imgData Byte
Byte array containing the encoded image.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface
analyze Overload


IProcessor.analyze(Stream) Method

IProcessoranalyze(Stream) Method

Looks for license plate candidates in a .jpg, .png or .tif encoded image loaded from a Stream. The images can be either 24 bit RGB or 8 bit gray scale.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze(
    Stream imgStream
)

Parameters

imgStream Stream
Stream from where to load the encoded image.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface
analyze Overload


IProcessor.analyze(String) Method

IProcessoranalyze(String) Method

Looks for license plate candidates in an image loaded from a .jpg, .png or .tif file. The images can be either 24 bit RGB or 8 bit gray scale.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze(
    string imgPath
)

Parameters

imgPath String
Path to a .jpg, .png or .tif file containing a 24 bit RGB or 8 bit gray scale image.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface
analyze Overload


IProcessor.analyze(IntPtr, UInt32, UInt32, UInt32) Method

IProcessoranalyze(IntPtr, UInt32, UInt32, UInt32) Method

Looks for license plate candidates in a memory buffer containing a 8 bit gray scale image.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze(
    IntPtr pImgData,
    uint widthStep,
    uint width,
    uint height
)

Parameters

pImgData IntPtr
Pointer to the first image row. The image must be 8 bit gray scale and top down: the top row of the image is the first row in memory, followed by the next row down.
widthStep UInt32
Distance in bytes between starts of consecutive rows in the source image.
width UInt32
Image width in pixels.
height UInt32
Image height in pixels.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface
analyze Overload


IProcessor.analyze_C3 Method

IProcessoranalyze_C3 Method

Looks for license plate candidates in a memory buffer containing a 3-channel 8 bit/channel color image stored in pixel order. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze_C3(
    IntPtr pImgData,
    uint widthStep,
    uint width,
    uint height,
    float fWeight0,
    float fWeight1,
    float fWeight2
)

Parameters

pImgData IntPtr
Pointer to the first image row. The image must be a 3-channel 8 bit/channel color image stored in pixel order and top down: the top row of the image is the first row in memory, followed by the next row down.
widthStep UInt32
Distance in bytes between starts of consecutive rows in the source image.
width UInt32
Image width in pixels.
height UInt32
Image height in pixels.
fWeight0 Single
Weight of the first channel.
fWeight1 Single
Weight of the second channel.
fWeight2 Single
Weight of the third channel.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface


IProcessor.analyze_C4 Method

IProcessoranalyze_C4 Method

Looks for license plate candidates in a memory buffer containing a 4-channel 8 bit/channel color image stored in pixel order. The fourth byte in each pixel is not used. Every pixel in the source image is internally converted to gray scale according to the following formula: L = fWeight0 * C0 + fWeight1 * C1 + fWeight2 * C2 For instance, to convert a RGB image to gray scale according the standard for the NTSC CRT the value of the weights should be: Red: fWeight0 = 0.299 Green: fWeight1 = 0.587 Blue: fWeight2 = 0.114

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
List<Candidate> analyze_C4(
    IntPtr pImgData,
    uint widthStep,
    uint width,
    uint height,
    float fWeight0,
    float fWeight1,
    float fWeight2
)

Parameters

pImgData IntPtr
Pointer to the first image row. The image must be a 3-channel 8 bit/channel color image stored in pixel order and top down: the top row of the image is the first row in memory, followed by the next row down.
widthStep UInt32
Distance in bytes between starts of consecutive rows in the source image.
width UInt32
Image width in pixels.
height UInt32
Image height in pixels.
fWeight0 Single
Weight of the first channel.
fWeight1 Single
Weight of the second channel.
fWeight2 Single
Weight of the third channel.

Return Value

List Candidate
List of Candidate containing all license plate candidates.
Remarks
This method is not multi-threaded.
See Also

Reference

IProcessor Interface


IProcessor.get_countryCode Method

IProcessorget_countryCode Method

Given a country index it returns its string identifier.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
string get_countryCode(
    uint id
)

Parameters

id UInt32
The country index. 0 <= id < numSupportedCountries - 1

Return Value

String
The country string identifier.
See Also

Reference

IProcessor Interface


IProcessor.get_countryWeight Method

IProcessorget_countryWeight Method

Overload List
 | Name | Description
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
See Also

Reference

IProcessor Interface


IProcessor.get_countryWeight(String) Method

IProcessorget_countryWeight(String) Method

Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
float get_countryWeight(
    string id
)

Parameters

id String
The country string identifier. get_countryCode(UInt32).

Return Value

Single
The relative weight of the country.
See Also

Reference

IProcessor Interface
get_countryWeight Overload


IProcessor.get_countryWeight(UInt32) Method

IProcessorget_countryWeight(UInt32) Method

Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
float get_countryWeight(
    uint id
)

Parameters

id UInt32
The country index. 0 <= id < numSupportedCountries - 1

Return Value

Single
The relative weight of the country.
See Also

Reference

IProcessor Interface
get_countryWeight Overload


IProcessor.realizeCountryWeights Method

IProcessorrealizeCountryWeights Method

Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void realizeCountryWeights()
Remarks
Depending on the countries selected this method can be time consuming. After the execution of this method the current instance of IProcessor will start using the new weights. Avoid calling this method when another thread is executing IProcessor.analyze.
See Also

Reference

IProcessor Interface


IProcessor.set_countryWeight Method

IProcessorset_countryWeight Method

Overload List
 | Name | Description
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
See Also

Reference

IProcessor Interface


IProcessor.set_countryWeight(String, Single) Method

IProcessorset_countryWeight(String, Single) Method

Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_countryWeight(
    string id,
    float val
)

Parameters

id String
The country string identifier. See get_countryCode.
val Single
The desired country weight. val >= 0
Remarks
Weight must be >= 0. Use a zero weight to effectively disable a specific country.
See Also

Reference

IProcessor Interface
set_countryWeight Overload


IProcessor.set_countryWeight(UInt32, Single) Method

IProcessorset_countryWeight(UInt32, Single) Method

Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_countryWeight(
    uint id,
    float val
)

Parameters

id UInt32
The country index. 0 <= id <= numSupportedCountries - 1
val Single
The desired country weight. val > 0
Remarks
Weight must be >= 0. Use a zero weight to effectively disable a specific country.
See Also

Reference

IProcessor Interface
set_countryWeight Overload


ISimpleLPR Interface

Encapsulates the SimpleLPR engine.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public interface ISimpleLPR : IDisposable

The ISimpleLPR type exposes the following members.

Properties
Name | Description
Public property | numSupportedCountries | Number of supported countries.
Public property versionNumber

Return Value

Gets the version number of SimpleLPR3_native.dll.
Top
Methods
 | Name | Description
Public method | createProcessor | Creates a new IProcessor object.
Public method | Dispose | (Inherited from IDisposable)
Public method | get_countryCode | Given a country index it returns its string identifier.
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | realizeCountryWeights | Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_productKey(Byte) | Sets the product key from a memory buffer.
Public method | set_productKey(String) | Sets the product key from a license file.
Top
See Also

Reference

SimpleLPR3 Namespace


ISimpleLPR Properties

The ISimpleLPR type exposes the following members.

Properties
Name | Description
Public property | numSupportedCountries | Number of supported countries.
Public property versionNumber

Return Value

Gets the version number of SimpleLPR3_native.dll.
Top
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.numSupportedCountries Property

ISimpleLPRnumSupportedCountries Property

Number of supported countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
uint numSupportedCountries { get; }

Property Value

UInt32
Number of supported countries.
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.versionNumber Property

ISimpleLPRversionNumber Property

Return Value

VersionNumber
Gets the version number of SimpleLPR3_native.dll.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
VersionNumber versionNumber { get; }

Property Value

VersionNumber
See Also

Reference

ISimpleLPR Interface


ISimpleLPR Methods

The ISimpleLPR type exposes the following members.

Methods
 | Name | Description
Public method | createProcessor | Creates a new IProcessor object.
Public method | Dispose | (Inherited from IDisposable)
Public method | get_countryCode | Given a country index it returns its string identifier.
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | realizeCountryWeights | Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_productKey(Byte) | Sets the product key from a memory buffer.
Public method | set_productKey(String) | Sets the product key from a license file.
Top
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.createProcessor Method

ISimpleLPRcreateProcessor Method

Creates a new IProcessor object.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
IProcessor createProcessor()

Return Value

IProcessor
The newly created IProcessor instance.
Remarks
For this method to succeed, either the product must be within the evaluation period o a valid product key must be supplied using set_productKey.
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.get_countryCode Method

ISimpleLPRget_countryCode Method

Given a country index it returns its string identifier.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
string get_countryCode(
    uint id
)

Parameters

id UInt32
The country index. 0 <= id < numSupportedCountries - 1

Return Value

String
The country string identifier.
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.get_countryWeight Method

ISimpleLPRget_countryWeight Method

Overload List
 | Name | Description
Public method | get_countryWeight(String) | Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | get_countryWeight(UInt32) | Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.get_countryWeight(String) Method

ISimpleLPRget_countryWeight(String) Method

Given a country string identifier it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
float get_countryWeight(
    string id
)

Parameters

id String
The country string identifier. get_countryCode(UInt32).

Return Value

Single
The relative weight of the country.
See Also

Reference

ISimpleLPR Interface
get_countryWeight Overload


ISimpleLPR.get_countryWeight(UInt32) Method

ISimpleLPRget_countryWeight(UInt32) Method

Given a country index it gets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
float get_countryWeight(
    uint id
)

Parameters

id UInt32
The country index. 0 <= id < numSupportedCountries - 1

Return Value

Single
The relative weight of the country.
See Also

Reference

ISimpleLPR Interface
get_countryWeight Overload


ISimpleLPR.realizeCountryWeights Method

ISimpleLPRrealizeCountryWeights Method

Builds the internal country verification lookup tables based on which countries are enabled and their relative weights. Call it once you have finished configuring country weights.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void realizeCountryWeights()
Remarks
Depending on the countries selected this method can be time consuming. After the execution of this method all existing and new IProcessor instances will start using the new weights. Avoid calling this method when another thread is executing IProcessor.analyze.
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.set_countryWeight Method

ISimpleLPRset_countryWeight Method

Overload List
 | Name | Description
Public method | set_countryWeight(String, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Public method | set_countryWeight(UInt32, Single) | Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.
Top
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.set_countryWeight(String, Single) Method

ISimpleLPRset_countryWeight(String, Single) Method

Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_countryWeight(
    string id,
    float val
)

Parameters

id String
The country string identifier. See get_countryCode(UInt32).
val Single
The desired country weight. val >= 0
Remarks
Weight must be >= 0. Use a zero weight to effectively disable a specific country.
See Also

Reference

ISimpleLPR Interface
set_countryWeight Overload


ISimpleLPR.set_countryWeight(UInt32, Single) Method

ISimpleLPRset_countryWeight(UInt32, Single) Method

Sets the country relative weight. Weights are used to break ties when a candidate can belong to multiple countries.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_countryWeight(
    uint id,
    float val
)

Parameters

id UInt32
The country index. 0 <= id <= numSupportedCountries - 1
val Single
The desired country weight. val > 0
Remarks
Weight must be >= 0. Use a zero weight to effectively disable a specific country.
See Also

Reference

ISimpleLPR Interface
set_countryWeight Overload


ISimpleLPR.set_productKey Method

ISimpleLPRset_productKey Method

Overload List
 | Name | Description
Public method | set_productKey(Byte) | Sets the product key from a memory buffer.
Public method | set_productKey(String) | Sets the product key from a license file.
Top
See Also

Reference

ISimpleLPR Interface


ISimpleLPR.set_productKey(Byte[]) Method

ISimpleLPRset_productKey(Byte) Method

Sets the product key from a memory buffer.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_productKey(
    byte[] productKey
)

Parameters

productKey Byte
Byte array containing the product key.
See Also

Reference

ISimpleLPR Interface
set_productKey Overload


ISimpleLPR.set_productKey(String) Method

ISimpleLPRset_productKey(String) Method

Sets the product key from a license file.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
void set_productKey(
    string productKeyPath
)

Parameters

productKeyPath String
Path to the product key file.
See Also

Reference

ISimpleLPR Interface
set_productKey Overload


SimpleLPR Class

SimpleLPR factory class.
Inheritance Hierarchy
SystemObject
SimpleLPR3SimpleLPR

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public sealed class SimpleLPR

The SimpleLPR type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object)
Public method | GetHashCode | (Inherited from Object)
Public method | GetType | (Inherited from Object)
 | Setup(EngineSetupParms) | Creates a ISimpleLPR object.
 | Setup(String, EngineSetupParms) | Creates a ISimpleLPR object loading 'SimpleLPR3_native.dll' from a user defined location.
Public method | ToString | (Inherited from Object)
Top
See Also

Reference

SimpleLPR3 Namespace


SimpleLPR Methods

The SimpleLPR type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object)
Public method | GetHashCode | (Inherited from Object)
Public method | GetType | (Inherited from Object)
 | Setup(EngineSetupParms) | Creates a ISimpleLPR object.
 | Setup(String, EngineSetupParms) | Creates a ISimpleLPR object loading 'SimpleLPR3_native.dll' from a user defined location.
Public method | ToString | (Inherited from Object)
Top
See Also

Reference

SimpleLPR Class


SimpleLPR.Setup Method

SimpleLPRSetup Method

Overload List
Name | Description
Setup(EngineSetupParms) | Creates a ISimpleLPR object.
Setup(String, EngineSetupParms) | Creates a ISimpleLPR object loading 'SimpleLPR3_native.dll' from a user defined location.
Top
See Also

Reference

SimpleLPR Class


SimpleLPR.Setup(EngineSetupParms) Method

SimpleLPRSetup(EngineSetupParms) Method

Creates a ISimpleLPR object.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public static ISimpleLPR Setup(
    EngineSetupParms parms
)

Parameters

parms EngineSetupParms
Engine setup parameters.

Return Value

ISimpleLPR
A ISimpleLPR instance.
See Also

Reference

SimpleLPR Class
Setup Overload


SimpleLPR.Setup(String, EngineSetupParms) Method

SimpleLPRSetup(String, EngineSetupParms) Method

Creates a ISimpleLPR object loading 'SimpleLPR3_native.dll' from a user defined location.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public static ISimpleLPR Setup(
    string sNativeFolderPath,
    EngineSetupParms parms
)

Parameters

sNativeFolderPath String
The path to the folder which contains the 'libSimpleLPR3' native library.
parms EngineSetupParms
Engine setup parameters.

Return Value

ISimpleLPR
A ISimpleLPR instance.
See Also

Reference

SimpleLPR Class
Setup Overload


VersionNumber Structure

Encapsulates the application version number.
Inheritance Hierarchy
SystemObject
SystemValueType
SimpleLPR3VersionNumber

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public struct VersionNumber

The VersionNumber type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | A | First element of the of SimpleLPR3_Native.dll product number.
Public field | B | Second element of the of SimpleLPR3_Native.dll product number.
Public field | C | Third element of the of SimpleLPR3_Native.dll product number.
Public field | D | Fourth element of the of SimpleLPR3_Native.dll product number.
Top
See Also

Reference

SimpleLPR3 Namespace


VersionNumber Methods

The VersionNumber type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from ValueType)
Public method | GetHashCode | (Inherited from ValueType)
Public method | GetType | (Inherited from Object)
Public method | ToString | (Inherited from ValueType)
Top
See Also

Reference

VersionNumber Structure


VersionNumber Fields

The VersionNumber type exposes the following members.

Fields
 | Name | Description
Public field | A | First element of the of SimpleLPR3_Native.dll product number.
Public field | B | Second element of the of SimpleLPR3_Native.dll product number.
Public field | C | Third element of the of SimpleLPR3_Native.dll product number.
Public field | D | Fourth element of the of SimpleLPR3_Native.dll product number.
Top
See Also

Reference

VersionNumber Structure


VersionNumber.A Field

VersionNumberA Field

First element of the of SimpleLPR3_Native.dll product number.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int A

Field Value

Int32
See Also

Reference

VersionNumber Structure


VersionNumber.B Field

VersionNumberB Field

Second element of the of SimpleLPR3_Native.dll product number.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int B

Field Value

Int32
See Also

Reference

VersionNumber Structure


VersionNumber.C Field

VersionNumberC Field

Third element of the of SimpleLPR3_Native.dll product number.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int C

Field Value

Int32
See Also

Reference

VersionNumber Structure


VersionNumber.D Field

VersionNumberD Field

Fourth element of the of SimpleLPR3_Native.dll product number.

Namespace: SimpleLPR3
Assembly: SimpleLPR3 (in SimpleLPR3.dll) Version: 3.5.1.0
Syntax
C#
Copy
public int D

Field Value

Int32
See Also

Reference

VersionNumber Structure